DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • April 23, 2018, 10:29:31 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1] 2   Go Down
  Print  
Author Topic: Installing error on 1.0.6  (Read 352 times)
0 Members and 1 Guest are viewing this topic.
ChesireCat
Captain of the Guard
***
Offline Offline

Posts: 102


View Profile WWW
« on: April 07, 2018, 10:19:48 AM »

Fatal error: Uncaught Error: Call to undefined function mysqli_proc_connect() in /home/vhosts/crystaltales.eu5.org/lib/dbwrapper.php:144 Stack trace: #0 /home/vhosts/crystaltales.eu5.org/common.php(124): db_connect(NULL, NULL, NULL) #1 /home/vhosts/crystaltales.eu5.org/installer.php(13): require_once('/home/vhosts/cr...') #2 {main} thrown in /home/vhosts/crystaltales.eu5.org/lib/dbwrapper.php on line 144

Hello, there first of all i know that i shouldn't even be installing an older unsuported version of the game, but the wizards/editors i wanna use don't seem compatible with the newest version of lotgd, i would like to request some help fixing the instalation errors, if anyone would be so kind to help me T.T
« Last Edit: April 07, 2018, 10:57:15 AM by ChesireCat » Logged

TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #1 on: April 07, 2018, 08:29:01 PM »

Fatal error: Uncaught Error: Call to undefined function mysqli_proc_connect() in /home/vhosts/crystaltales.eu5.org/lib/dbwrapper.php:144 Stack trace: #0 /home/vhosts/crystaltales.eu5.org/common.php(124): db_connect(NULL, NULL, NULL) #1 /home/vhosts/crystaltales.eu5.org/installer.php(13): require_once('/home/vhosts/cr...') #2 {main} thrown in /home/vhosts/crystaltales.eu5.org/lib/dbwrapper.php on line 144

Hello, there first of all i know that i shouldn't even be installing an older unsuported version of the game, but the wizards/editors i wanna use don't seem compatible with the newest version of lotgd, i would like to request some help fixing the instalation errors, if anyone would be so kind to help me T.T

OK...let me ask a few questions I know are gonna get asked that may help to help you?

1. What version of PHP are you using, and what version of MySQL?  You should find this in the Control Panel on your server.

2. What step in the install process do you have this problem?

3. did you upload a database to your server before you started the install?  It is my understanding you must first upload a database, even a rudimentary one.

4. do you have a file on your server called db_connect.php?  If so, delete it and re-run the install.  The install should create this file FOR YOU...so you don't want it there when you start the install (this usually hangs you up like on Step 8 if I recall it correctly)

At some point along later versions of PHP I know that the Mysql_Connect needs to be changed to db_connect (I am sure I have seen this floating around here somewhere) - so it's helpful to peoplke if it is known what version of PHP your server is running.

That should get some help started, if you can answer these questions.
Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1863


You're welcome.


View Profile WWW
« Reply #2 on: April 07, 2018, 09:11:42 PM »

Hello, there first of all i know that i shouldn't even be installing an older unsuported version of the game, but the wizards/editors i wanna use don't seem compatible with the newest version of lotgd, i would like to request some help fixing the instalation errors, if anyone would be so kind to help me T.T

"Unsupported" typically means that yes, it's unsupported and there's little help for it.

What editors won't work with it? I recommend using the updated code, and then adapting those editors to work with it. It's better to use the correct system and make a few small changes, then to use an outdated system that is weak on its security just so a module or two will work.
Logged

TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #3 on: April 08, 2018, 06:53:19 AM »

Agreeing with you, Aeolus, but if Cheshire really does want, for whatever reason, to do 1.0.6 - I am guessing the problem could be a function that was changed in higher versions of PHP

What jumped at me is this:

mysqli_proc_connect(

Because if you do a Google search on that, it does not even come up.  

What does come back is mysqli_real_connect(

or just

mysqli_connect(

I know I had trouble, a while back, with my 1.1.0 live site...when my server vendor upgraded my version of PHP without telling me and sure enough it broke things and I had to fix them.

I am still actively working on my 1.1.2 test server, literally testing everything to the breaking point, to make sure everything works as I want before converting my live site to 1.1.2

I'm still not even certain I can import the 1.1.0 database over, so that players don't have to start over when I do a conversion...so I am also seeing what I ca accumulate in a given number of kills, so I can start experienced players out with some kind of bonus stuff if the database from the old site won't go to the new site.
« Last Edit: April 08, 2018, 06:58:30 AM by TGTarheel » Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1863


You're welcome.


View Profile WWW
« Reply #4 on: April 08, 2018, 07:08:13 AM »

Then use 1.0.6 on a test server. Use 1.1.2+Updates on the live server.
Logged

TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #5 on: April 08, 2018, 07:17:57 AM »

Then use 1.0.6 on a test server. Use 1.1.2+Updates on the live server.

I'm working on it!!!

My live site will go 1.1.2 - just a matter of resolving a few things...like I may be changing hosts...and if I do, may as well start fresh with the 1.1.2 on a new host...just need to figure if I can transfer in the old database or not.

Everything I have going on now, on the 1.1.2 test server functions correctly, I am working more on aesthetics and a few features.

Also testing out something on my live site, which I will need to release here once it fully tests...I created a new Specialty, based on the other "Mana" Specialties.  But first I have to ring it all the way up to make sure everything works like it is supposed to.  Because it is based on the original Mana Specialties by Aelia, I will need to release it once it all tests out...and with proper author crediting.
Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1863


You're welcome.


View Profile WWW
« Reply #6 on: April 08, 2018, 07:22:33 AM »

I was actually talking about/to ChesireCat and their site.

Yes, you can transfer in the old database. Export the current database through whatever backup method you use, import it into the new host's database.
Logged

TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #7 on: April 08, 2018, 07:32:45 AM »

I was actually talking about/to ChesireCat and their site.

Yes, you can transfer in the old database. Export the current database through whatever backup method you use, import it into the new host's database.

I know that.  What I am NOT sure of...is if the old 1.1.0 database will work with some of the new 1.1.2 stuff.  For example, 1.1.0 does not have AI for forest creatures, and 1.1.2 does...would the old table work and the install add the appropriate column?

That is the sort of thing I do not know.
Logged
Brendan
I am Brendan.
Mod God
*****
Offline Offline

Posts: 866


View Profile
« Reply #8 on: April 08, 2018, 08:41:45 AM »

You should never mix the install with the database. If your using 1.1.0 then use the 1.1.0 database, if your using 1.1.2 use the 1.1.2 database. Otherwise you will find yourself running into a lot of problems.
Logged
TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #9 on: April 08, 2018, 08:52:46 AM »

You should never mix the install with the database. If your using 1.1.0 then use the 1.1.0 database, if your using 1.1.2 use the 1.1.2 database. Otherwise you will find yourself running into a lot of problems.

That was what I thought.

Thus...I will NOT be able to save my players' stuff in an upgrade to 1.1.2 - will I?
Logged
Talisman
Administrator
Mod God
*****
Offline Offline

Posts: 5479



View Profile WWW
« Reply #10 on: April 08, 2018, 10:56:46 AM »

You should never mix the install with the database. If your using 1.1.0 then use the 1.1.0 database, if your using 1.1.2 use the 1.1.2 database. Otherwise you will find yourself running into a lot of problems.

That was what I thought.

Thus...I will NOT be able to save my players' stuff in an upgrade to 1.1.2 - will I?

You could, with work.  Using a test server to develop the process of course, you'll need to determine what fields are missing altogether and/or missing the old data and create a custom db query to pull that information from the 1.1.0 db then update the 1.1.2 db. 
Logged

Play the latest beta version here on DragonPrime
TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #11 on: April 08, 2018, 04:42:57 PM »

You should never mix the install with the database. If your using 1.1.0 then use the 1.1.0 database, if your using 1.1.2 use the 1.1.2 database. Otherwise you will find yourself running into a lot of problems.

That was what I thought.

Thus...I will NOT be able to save my players' stuff in an upgrade to 1.1.2 - will I?

You could, with work.  Using a test server to develop the process of course, you'll need to determine what fields are missing altogether and/or missing the old data and create a custom db query to pull that information from the 1.1.0 db then update the 1.1.2 db. 

OK, not sure how you do this.

Just as an example...on my 1.1.2 test server, I imported my 1.1.0 creatures database - this is how I found out about the missing AI column, because now, on my test server, I can't add creatures through the Creature editor, I literally have to manually add them thru PHP My Admin.

So...one mistake I will not do when I go live with 1.1.2 is to do what I did on the test server, LOL
Logged
ChesireCat
Captain of the Guard
***
Offline Offline

Posts: 102


View Profile WWW
« Reply #12 on: April 09, 2018, 05:56:48 PM »

Quote
"Unsupported" typically means that yes, it's unsupported and there's little help for it.

What editors won't work with it? I recommend using the updated code, and then adapting those editors to work with it. It's better to use the correct system and make a few small changes, then to use an outdated system that is weak on its security just so a module or two will work.

Completely understand your point aeolus, but due to my limited(non existent) coding skills i do rely on modules and wizards to be able to convert my ideas into aplicable game ideas, the module in question are mana specialties by thanatos, although aelias specialties are quite superior mechanical wise they are also much more complex and harder to customise what i'm aiming for is  a good illuison of specialty mastery or progress , while looking around through the threads i read something about the modules who create DB tables, seem to conflict a bit on 1.1.2, so i tried to install 1.0.6 wich i remember worked with it flawlessly a few years ago


Quote
OK...let me ask a few questions I know are gonna get asked that may help to help you?

1. What version of PHP are you using, and what version of MySQL?  You should find this in the Control Panel on your server.

2. What step in the install process do you have this problem?

3. did you upload a database to your server before you started the install?  It is my understanding you must first upload a database, even a rudimentary one.

4. do you have a file on your server called db_connect.php?  If so, delete it and re-run the install.  The install should create this file FOR YOU...so you don't want it there when you start the install (this usually hangs you up like on Step 8 if I recall it correctly)

At some point along later versions of PHP I know that the Mysql_Connect needs to be changed to db_connect (I am sure I have seen this floating around here somewhere) - so it's helpful to peoplke if it is known what version of PHP your server is running.

1- PHP 7.1,
database server to MariaDB 10.2
and apache to version 2.4.

2-Straight of the bat once i click game installer that error pops out

3-Did not upload any db, created one from scratch for the server test

4-Answer number 3


« Last Edit: April 09, 2018, 06:07:48 PM by ChesireCat » Logged

TGTarheel
Codemeister
****
Offline Offline

Posts: 397


View Profile
« Reply #13 on: April 09, 2018, 09:44:52 PM »

Quote
"Unsupported" typically means that yes, it's unsupported and there's little help for it.

What editors won't work with it? I recommend using the updated code, and then adapting those editors to work with it. It's better to use the correct system and make a few small changes, then to use an outdated system that is weak on its security just so a module or two will work.

Completely understand your point aeolus, but due to my limited(non existent) coding skills i do rely on modules and wizards to be able to convert my ideas into aplicable game ideas, the module in question are mana specialties by thanatos, although aelias specialties are quite superior mechanical wise they are also much more complex and harder to customise what i'm aiming for is  a good illuison of specialty mastery or progress , while looking around through the threads i read something about the modules who create DB tables, seem to conflict a bit on 1.1.2, so i tried to install 1.0.6 wich i remember worked with it flawlessly a few years ago


Quote
OK...let me ask a few questions I know are gonna get asked that may help to help you?

1. What version of PHP are you using, and what version of MySQL?  You should find this in the Control Panel on your server.

2. What step in the install process do you have this problem?

3. did you upload a database to your server before you started the install?  It is my understanding you must first upload a database, even a rudimentary one.

4. do you have a file on your server called db_connect.php?  If so, delete it and re-run the install.  The install should create this file FOR YOU...so you don't want it there when you start the install (this usually hangs you up like on Step 8 if I recall it correctly)

At some point along later versions of PHP I know that the Mysql_Connect needs to be changed to db_connect (I am sure I have seen this floating around here somewhere) - so it's helpful to peoplke if it is known what version of PHP your server is running.

1- PHP 7.1,
database server to MariaDB 10.2
and apache to version 2.4.

2-Straight of the bat once i click game installer that error pops out

3-Did not upload any db, created one from scratch for the server test

4-Answer number 3




Well, I see part of your problem already.  PHP 7.1
My understanding is that LOTGD as it is currently (even version 1.1.2) WILL NOT WORK with PHP 7.

Mainly, I think because of a number of functions that have been degraded in later versions of PHP.

I think this is where the mysqli_connect thing is gonna come up...let me look around and see if I can find what I was referencing.


YESSSSS...here it is, and our friend Aeolus wrote it...

Replace all mysql_ functions with db_ in the dbwrapper files.

Here is the thread reference: http://dragonprime.net/index.php?topic=12866.0

Notice they were having the same problem with PHP 7.

I knew this was floating out there somewhere, which is why I asked you the questions I did at the top of this thread.

Try Aeolus' solution there, replace the mysql_ functions with db_ in the dbwrapper file.
« Last Edit: April 09, 2018, 09:51:03 PM by TGTarheel » Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1863


You're welcome.


View Profile WWW
« Reply #14 on: April 09, 2018, 09:54:35 PM »

My understanding is that LOTGD as it is currently (even version 1.1.2) WILL NOT WORK with PHP 7.

Where did you get that? Fandom Kingdom is running PHP 7.0.28 perfectly.
Logged

Pages: [1] 2   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Please take the time to read the FAQ and browse the DragonPedia

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
32 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search