DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • September 26, 2017, 05:53:55 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1] 2   Go Down
  Print  
Author Topic: Fatal error: Maximum function nesting level of '100' reached, aborting! Solved!  (Read 4439 times)
0 Members and 1 Guest are viewing this topic.
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« on: May 29, 2016, 10:09:59 AM »

Hi.
I have a problem. I'm using a local server for Windows to run LotGD 1.1.2. This one: Denwer.
It contains:
PHP 5.3.13 + xdebug
Apache 2.2.22
MySQL 5.5.25
phpMyAdmin 3.5.1
LotGD was installed without any problems. My problem arrived only on home page: http://localhost/lotgd/home.php
Quote
Fatal error: Maximum function nesting level of '100' reached, aborting! in X:\home\localhost\www\lotgd\lib\datetime.php on line 154

xdebug is disabled:
xdebug.remote_autostart=0
xdebug.remote_enable=0
xdebug.profiler_enable=0
« Last Edit: June 01, 2016, 02:51:16 PM by Klervil » Logged
Stephen.Kise
Codemeister
****
Offline Offline

Posts: 367


So meme'd up.


View Profile
« Reply #1 on: May 29, 2016, 10:40:51 AM »

Hi.
I have a problem. I'm using a local server for Windows to run LotGD. This one: Denwer.
It contains:
PHP 5.3.13 + xdebug
Apache 2.2.22
MySQL 5.5.25
phpMyAdmin 3.5.1
LotGD was installed without any problems. My problem arrived only on home page: http://localhost/lotgd/home.php
Quote
Fatal error: Maximum function nesting level of '100' reached, aborting! in X:\home\localhost\www\lotgd\lib\datetime.php on line 154

xdebug is disabled:
xdebug.remote_autostart=0
xdebug.remote_enable=0
xdebug.profiler_enable=0


Odd that the root cause is xdebug, even if it is disabled. Go ahead and adjust your php.ini, and set your xdebug.max_nesting_level to around 200.
Logged

Slowly progressing fork with PHP 7 support: https://github.com/stephenKise/Legend-of-the-Green-Dragon
Cheap VPS Hosting (10$ credit!): https://m.do.co/c/acde75b086c5
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #2 on: May 29, 2016, 11:12:50 AM »

Done. Set to 200. Restart Denwer, but nothing. Still get that error.
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #3 on: May 30, 2016, 12:43:52 AM »

Any suggestions? Smiley
Logged
Stephen.Kise
Codemeister
****
Offline Offline

Posts: 367


So meme'd up.


View Profile
« Reply #4 on: May 30, 2016, 02:51:25 AM »

Done. Set to 200. Restart Denwer, but nothing. Still get that error.
Did you install all of the core fixes? Mainly the ones to patch the split() deprecation? That could effect the microtime functionality. Enable Xdebug and see what it gives you. I have never had such an issue like this before, but it has been ages that I have used 5.3.
Logged

Slowly progressing fork with PHP 7 support: https://github.com/stephenKise/Legend-of-the-Green-Dragon
Cheap VPS Hosting (10$ credit!): https://m.do.co/c/acde75b086c5
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #5 on: May 30, 2016, 02:59:29 AM »

Thanks. I'll try. Smiley
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #6 on: May 30, 2016, 12:39:29 PM »

Well... I've updated xdebug to version 2.2.7. Now I have another fatal error:
Quote
Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 261904 bytes) in X:\home\localhost\www\lotgd\lib\settings.php on line 61
Previous error is gone.
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #7 on: May 30, 2016, 12:42:19 PM »

Changing limit from 64 to 128 gave nothing.
Quote
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 580 bytes) in X:\home\localhost\www\lotgd\lib\dbwrapper_mysql.php on line 9
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #8 on: May 30, 2016, 02:27:44 PM »

Any ideas? Huh
Logged
WereMagi
Militia
**
Offline Offline

Posts: 87


I like trains.


View Profile
« Reply #9 on: May 31, 2016, 09:28:32 PM »

Have you tried reinstalling?
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #10 on: June 01, 2016, 02:35:17 AM »

Yes. The same errors on a different machines (Windows 7 x32 & x64).
I tried yesterday to run LotGD on another local server - error again.
« Last Edit: June 01, 2016, 08:08:38 AM by Klervil » Logged
MarcTheSlayer
Mod God
*****
Offline Offline

Posts: 1740


View Profile
« Reply #11 on: June 01, 2016, 06:48:24 AM »

You've added it to the php.ini file and it didn't work, but try it here anyhow. Smiley

root/lib/local_config.php

Code:
// Add anywhere in the file.
ini_set('xdebug.max_nesting_level', 200);
Logged

Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #12 on: June 01, 2016, 08:14:44 AM »

You've added it to the php.ini file and it didn't work, but try it here anyhow. Smiley

root/lib/local_config.php

Code:
// Add anywhere in the file.
ini_set('xdebug.max_nesting_level', 200);
That's what I've got:
Quote
Fatal error: Maximum function nesting level of '200' reached, aborting! in X:\home\localhost\www\lotgd.ru\lib\settings.php on line 34
Logged
Klervil
Militia
**
Offline Offline

Posts: 18



View Profile
« Reply #13 on: June 01, 2016, 02:49:22 PM »

Well, mates... My problem has been solved.
My bad.  Smiley I had not noticed some errors during the 10th step of installation.
Quote
Synchronizing table accounts..
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Type=INNODB' at line 102
I've changed one line in tabledescriptor.php like in this thread.
And that's all!
Thanks to all for your suggestions in any case. Smiley
Logged
Stephen.Kise
Codemeister
****
Offline Offline

Posts: 367


So meme'd up.


View Profile
« Reply #14 on: June 01, 2016, 08:39:54 PM »

Well, mates... My problem has been solved.
My bad.  Smiley I had not noticed some errors during the 10th step of installation.
Quote
Synchronizing table accounts..
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Type=INNODB' at line 102
I've changed one line in tabledescriptor.php like in this thread.
And that's all!
Thanks to all for your suggestions in any case. Smiley

Hey, make sure you apply the rest of the core fixes! You can find a link to a core with all of the patches in Aelous' signature.
Logged

Slowly progressing fork with PHP 7 support: https://github.com/stephenKise/Legend-of-the-Green-Dragon
Cheap VPS Hosting (10$ credit!): https://m.do.co/c/acde75b086c5
Pages: [1] 2   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Welcome to DragonPrime - The LoGD Resource Community!

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
17 Guests, 1 User
Aeolus
Home Forums News Downloads Login Register Advanced Search