DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • March 22, 2018, 10:19:36 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Resource Pages

Pages: [1]   Go Down
Author Topic: Module Database Tables Not Creating  (Read 757 times)
0 Members and 1 Guest are viewing this topic.
« on: May 12, 2014, 12:38:24 PM »


I seem to be having a few problems when it comes to installing some modules which create a table in the database.
I have tested a few modules and found differing results.

Dwellings, Cityprefs work and create the table.

Creationaddon, Pets, Drinks install but do not create the table.

I've made the type=$type to engine=$type adjustment as suggested in other threads, but this is giving me a headache and I cannot for the life of me figure out why.

I have done some searches and they all seem to lead to the above, but as I said, I have made that changed and no improvement.

Game running version is 1.1.2, no core edits aside from outputs have been done.

Is there something I am missing with some modules and the code to create a table in the database?

I really would appreciate any and all help.


After taking a closer look at the modules in question, the only major difference is the code around how the table is created.

I've now tried an updated Pet Shop and it has worked.

So my next question would be, for any "older" modules, would the create table code need updating?
« Last Edit: May 12, 2014, 12:58:21 PM by Dany » Logged
Offline Offline

Posts: 323

View Profile
« Reply #1 on: January 09, 2018, 08:21:58 PM »

Having same problem with Pets myself on 1.1.2 - where is this updated version of the pets you found?
Pages: [1]   Go Up
Jump to:  

DragonPrime Notices
Version 1.1.2 is the current supported version and is available for download.

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
33 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search