DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • November 23, 2017, 03:03:20 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: 1 2 3 [4] 5   Go Down
  Print  
Author Topic: File Discussion: Multi Poke  (Read 10724 times)
0 Members and 1 Guest are viewing this topic.
Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #45 on: November 11, 2012, 02:20:31 AM »

All done. ^^
Logged

RaynDarren
Mod God
*****
Offline Offline

Posts: 732


View Profile WWW
« Reply #46 on: November 11, 2012, 02:09:47 PM »

Awesome! Thank you ever so much!
Logged

Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #47 on: February 02, 2014, 12:00:46 AM »

Version 1.5: (Available in File Submission)

  • Limit the number of pokes a player can use in a game day.
  • New pref to block user from being able to use pokes on anyone, in case of abuse of the module.
  • New nav in bios to allow a user to show/hide the list of pokes, to avoid cluttering.
  • Issue of ^P^ and ^U^ not being subsituted for names in the news is now fixed.
  • "Display" link in Pokes Editor now fixed, since some wouldn't work (silly use of same variable twice - fault on my part).
  • Tidying up of Javascript code.
  • The editor scrolls into view when you're editing a certain poke, instead of having to scroll down.
Logged

JP
Militia
**
Offline Offline

Posts: 30



View Profile
« Reply #48 on: February 08, 2014, 10:01:55 AM »

Not sure if this was checked, but there appears to be an issue on my test server when performing a poke from a dwelling post.

The page seems to break.

Is it a redirect issue or an issue calling the account in the dwelling?

May look into sometime later today.
« Last Edit: February 27, 2014, 03:27:30 PM by johny2k9 » Logged
JP
Militia
**
Offline Offline

Posts: 30



View Profile
« Reply #49 on: February 27, 2014, 03:28:06 PM »

Had a few comp issues, but got to take a look at it today.

The issue occurs here: (Line 111)
Code:
addnav("$nav","runmodule.php?module=multipoke&op=$op&id={$row['id']}&char=$char&ret=$ret");

My fix for the issue:
Replace the previous line with this

Code:
addnav("$nav","runmodule.php?module=multipoke&op=$op&id={$row['id']}&char=$char"."&ret=".urlencode($ret)."");


Of course, if you're not experiencing any changes when making a poke in the dwelling best to disregard this... and if you do use it try it on a test server first. Bit crude, but should work.  Smiley

This also fixed another issue I had with performing a poke through the clan editor in a clan with player commentary.

Awesome module Doctor! I love everything about it.  Grin
« Last Edit: March 03, 2014, 05:07:53 PM by JP » Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #50 on: February 27, 2014, 05:33:00 PM »

Thanks for the bug report; glad you like it. Cheesy
Logged

Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #51 on: July 27, 2016, 01:17:18 AM »

Bug fix:

The module allows Player A to poke Player B even if Player B has added Player A to their ignore list (via the friend list module). To fix this:

Find:
Code:
output("`^You can't do this action to yourself!`n`n");
Add after:
Code:
} elseif (in_array($player['acctid'], explode('|',get_module_pref('ignored','friendlist')))) {
output("`QThis user has ignored you, so you cannot send them a poke.");
Logged

TGTarheel
Captain of the Guard
***
Offline Offline

Posts: 169


View Profile
« Reply #52 on: September 01, 2017, 12:36:43 PM »

So does this module like, completely work now?

Can I plug and play it into my 1.1.0 server?

I know, I know...a lot of people here hate older versions of the core but I don't.
Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #53 on: September 01, 2017, 04:39:38 PM »

So does this module like, completely work now?

Can I plug and play it into my 1.1.0 server?

I know, I know...a lot of people here hate older versions of the core but I don't.

I have no intention of making it compatible with an older server of the core. It's not that I "hate" the older versions, it's that I have no interest is supporting versions without bug fixes and with security flaws that put players as risk.

Best you can do is just try it on a test server and see if it works.
Logged

TGTarheel
Captain of the Guard
***
Offline Offline

Posts: 169


View Profile
« Reply #54 on: September 02, 2017, 08:11:50 AM »

So does this module like, completely work now?

Can I plug and play it into my 1.1.0 server?

I know, I know...a lot of people here hate older versions of the core but I don't.

I have no intention of making it compatible with an older server of the core. It's not that I "hate" the older versions, it's that I have no interest is supporting versions without bug fixes and with security flaws that put players as risk.

Best you can do is just try it on a test server and see if it works.

I did it and it works on 1.1.0
And I have no intention of updating my core to a later version that does not support certain things I need supported.
FWIW:  When the core gets updated, they should MAKE SURE the new core is compatible with everything that came before...if they want people to update.
Core past 1.1.0 does not support Alternate Currencies and my game is dependent on them...without them, my game would not be the game it is and I would have to modify 90 percent of my game.  Not gonna do it.

I don't even know if later version of the core support the Item System, and that, right there, would be a huge deal-breaker.
« Last Edit: September 02, 2017, 08:15:46 AM by TGTarheel » Logged
Stephen.Kise
Codemeister
****
Offline Offline

Posts: 377


So meme'd up.


View Profile
« Reply #55 on: September 02, 2017, 02:35:00 PM »

So does this module like, completely work now?

Can I plug and play it into my 1.1.0 server?

I know, I know...a lot of people here hate older versions of the core but I don't.

I have no intention of making it compatible with an older server of the core. It's not that I "hate" the older versions, it's that I have no interest is supporting versions without bug fixes and with security flaws that put players as risk.

Best you can do is just try it on a test server and see if it works.

I did it and it works on 1.1.0
And I have no intention of updating my core to a later version that does not support certain things I need supported.
FWIW:  When the core gets updated, they should MAKE SURE the new core is compatible with everything that came before...if they want people to update.
Core past 1.1.0 does not support Alternate Currencies and my game is dependent on them...without them, my game would not be the game it is and I would have to modify 90 percent of my game.  Not gonna do it.

I don't even know if later version of the core support the Item System, and that, right there, would be a huge deal-breaker.

Quite hard to do if you are going to update the core to current standards, like following the PSR.
Logged

Slowly progressing fork with PHP 7 support: https://github.com/stephenKise/Legend-of-the-Green-Dragon
Cheap VPS Hosting (10$ credit!): https://m.do.co/c/acde75b086c5
TGTarheel
Captain of the Guard
***
Offline Offline

Posts: 169


View Profile
« Reply #56 on: September 02, 2017, 03:01:30 PM »

So does this module like, completely work now?

Can I plug and play it into my 1.1.0 server?

I know, I know...a lot of people here hate older versions of the core but I don't.

I have no intention of making it compatible with an older server of the core. It's not that I "hate" the older versions, it's that I have no interest is supporting versions without bug fixes and with security flaws that put players as risk.

Best you can do is just try it on a test server and see if it works.

I did it and it works on 1.1.0
And I have no intention of updating my core to a later version that does not support certain things I need supported.
FWIW:  When the core gets updated, they should MAKE SURE the new core is compatible with everything that came before...if they want people to update.
Core past 1.1.0 does not support Alternate Currencies and my game is dependent on them...without them, my game would not be the game it is and I would have to modify 90 percent of my game.  Not gonna do it.

I don't even know if later version of the core support the Item System, and that, right there, would be a huge deal-breaker.

Quite hard to do if you are going to update the core to current standards, like following the PSR.

Like I said...no Item System...complete deal-breaker.
Logged
Aeolus
Mod God
*****
Offline Offline

Posts: 1792


You're welcome.


View Profile WWW
« Reply #57 on: September 02, 2017, 04:28:40 PM »

Like I said...no Item System...complete deal-breaker.

1) Item System, or 2) required bug fixes and better security measures... I know what I would want for my players. I hope that you're going to let your players know about your choice as well.
Logged

TGTarheel
Captain of the Guard
***
Offline Offline

Posts: 169


View Profile
« Reply #58 on: September 03, 2017, 08:40:23 AM »

Like I said...no Item System...complete deal-breaker.

1) Item System, or 2) required bug fixes and better security measures... I know what I would want for my players. I hope that you're going to let your players know about your choice as well.

Without the Item System, my entire game is shot.  Others run 1.1.0 and Central even runs 1.0.6 so gimme a break, okay??

Security against WHAT??  Even so, no sooner that new "security" stuff is done hackers find a way to break it, so I seriously doybt even 1.1.2 is all that bloody "secure"
Logged
Stephen.Kise
Codemeister
****
Offline Offline

Posts: 377


So meme'd up.


View Profile
« Reply #59 on: September 03, 2017, 01:23:45 PM »

Like I said...no Item System...complete deal-breaker.

1) Item System, or 2) required bug fixes and better security measures... I know what I would want for my players. I hope that you're going to let your players know about your choice as well.

Without the Item System, my entire game is shot.  Others run 1.1.0 and Central even runs 1.0.6 so gimme a break, okay??

Security against WHAT??  Even so, no sooner that new "security" stuff is done hackers find a way to break it, so I seriously doybt even 1.1.2 is all that bloody "secure"

Central runs 1.0.6 because there is no affiliation with DragonPrime. It's old, dead code, online for the sake of being online. Anyone who has 1.1.0 is not up-to-date and probably is doing the same - just being online to be online, without updating their servers. There is a bug in 1.1.0 where anyone can set ANY module preference to ANY value they want. Anyone with the creature editor has access to everything on the server. Upgrading is key. Upgrade the items system, don't downgrade a version for legacy modules. 1.1.2 and further revisions are much more secure.
Logged

Slowly progressing fork with PHP 7 support: https://github.com/stephenKise/Legend-of-the-Green-Dragon
Cheap VPS Hosting (10$ credit!): https://m.do.co/c/acde75b086c5
Pages: 1 2 3 [4] 5   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Play LoGD on Dragonprime

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
22 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search