DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • July 27, 2016, 10:13:30 AM
Home Forums News Links Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
IRC Channels
Search

Pages: [1]   Go Down
  Print  
Author Topic: Mounts for different cities.  (Read 2543 times)
0 Members and 1 Guest are viewing this topic.
Ariadoss
Member
Captain of the Guard
***
Offline Offline

Posts: 139


HogwartsLive.com


View Profile WWW
« on: September 25, 2004, 05:27:30 PM »

Well this should be a very easy question to answer, when I go to the Mount Editor under Superuser Grotto, I find that I am unable to change Mount Availability: I figured this is because it is missing the proper table in the database, or perhaps some code?  I would like to know whether or not the ability to choose the village the mount is available in is supposed to function properly, and if yes, which pages or tables effect this?
Logged

SaucyWench
Mod God
*****
Offline Offline

Posts: 2238


I'm a good girl.


View Profile WWW
« Reply #1 on: September 25, 2004, 09:40:20 PM »

Hrm. It's working in the Playground (dragoncat beta)... I've just created a new mount and I can change its sale location sucessfully.

I have to wonder if it might possibly be the setup of the HWL server, with things like the stables being renamed. It is VERY unlike Kendaer to hard code anything, so I doubt the selector uses village names specifically... but he will be back in town tomorrow, so we can ask him then.

EDIT: You're running PRE 2. The changesettings() function needs *I think* PRE 5. I'm 90% sure that is why the settings changer doesn't work!
« Last Edit: September 25, 2004, 09:43:21 PM by SaucyWench » Logged

SaucyWench
Owner of GemDust.com and Darton City proudly hosted by LunarPages
Ariadoss
Member
Captain of the Guard
***
Offline Offline

Posts: 139


HogwartsLive.com


View Profile WWW
« Reply #2 on: September 26, 2004, 09:30:02 PM »

Thanks I play around with it, see if something works.
Logged

Kendaer
Guest
« Reply #3 on: September 27, 2004, 01:07:51 AM »

Your code is based on pre-2.  That code has not been supported for quite a while now (about 6 weeks).

Sorry, you're on your own.

Personally, I'd recommend upgrading to the most recent core code.
Logged
AndyMC
Guest
« Reply #4 on: September 29, 2004, 10:35:21 PM »

I'm actually having a similar problem but with PRE8, when I change the location on a mount from Everywhere to a specific city, and click save, I get a message similar to the following (and it doesn't save):

Code:
Mount not saved: UPDATE mounts SET mountname='Stallion',mountdesc='This noble beast is huge and powerful!',mountcategory='Horses',mountdkcost='0',mountcostgems='16',mountcostgold='0',mountfeedcost='20',mountforestfights='3',newday='You strap your {weapon} to your stallion\'s saddle bags, and head out for some adventure!',recharge='Remembering that is has been quite some time since you last fed your stallion, you decide this is a perfect time to relax and allow it to graze the field a bit. You doze off enjoying this peaceful serenity.',partrecharge='You dismount in the field to allow your stallion to graze for a moment even though it has recently been fully fed. As you lean back in the grass to watch the clouds, your stallion whickers softly and trots off into the underbrush. You search for a while before returning to the fields hoping that it\'ll return. A short time later, your stallion trots back into the clearing holding its head high, looking much more energized and with a very equine grin on its face.',mountbuff='a:5:{s:4:\"name\";s:17:\"Stallion Attack\";s:8:\"roundmsg\";s:30:\"Your stallion fights with you!\";s:6:\"rounds\";s:2:\"60\";s:6:\"atkmod\";s:3:\"1.2\";s:6:\"schema\";s:6:\"mounts\";}' WHERE mountid='3'

That example is the message I got after trying to change the default Stallion to a specific city location
Logged
Kendaer
Guest
« Reply #5 on: September 30, 2004, 05:51:21 PM »

This does seem to be occuring on my dragonat logd-beta.dragoncat.net server as well.  I'll look into it and fix it as soon as I'm over this illness that has me laid low.
Logged
Sichae
iMod God
SVN Users
Mod God
*
Offline Offline

Posts: 3458


If ya didn't get it by now... you're hopeless...


View Profile WWW
« Reply #6 on: September 30, 2004, 06:42:38 PM »

:frowns and then sneezes:

Exeryone has been getting sick lately...it really sucks...  Embarrassed
Logged

If you didn't understand anything in the above post, don't try to attempt anything suggested.

Kendaer
Guest
« Reply #7 on: October 01, 2004, 10:02:10 AM »

Found the bug and boy was it stupid.

find the line in mount.php which reads
Code:
rawoutput("<select name='mountlocation'>");

and change it to
Code:
rawoutput("<select name='mount[mountlocation]'>");

That should fix you.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Version 1.1.2 is the current supported version and is available for download.

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Who's Online
50 Guests, 0 Users
DragonPrime LoGD
Recent Topics
Home Forums News Links Downloads Login Register Advanced Search