DragonPrime - LoGD Resource Community
Welcome Guest
  • Good afternoon, Guest.
    Please log in, or register.
  • May 29, 2016, 02:01:36 PM
Home Forums News Links Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
IRC Channels
Search

Pages: [1]   Go Down
  Print  
Author Topic: checking for battle  (Read 2513 times)
0 Members and 1 Guest are viewing this topic.
kodysumter
Guest
« on: July 22, 2004, 11:07:26 AM »

how do i check if a person is in a battle like if ($battle=true) or something like that....how would i check, the prob is people are using the badnav to cheat and win gold and or dk and or beat masters insanly alot just hit back and then forth....well i know it is my server that is not configured properly but i can handle that, i am hosted, and my dumb mac wont take php right now..(if anyone knows how to install php on mac OSX 10.1.5 tell me pls)
Logged
kodysumter
Guest
« Reply #1 on: July 22, 2004, 01:20:47 PM »

still noone posted  Cry i need this....the people are cheating and i have to tell them to stop....and checking every players dks and debug log is getting tedous
Logged
anpera
Guest
« Reply #2 on: July 23, 2004, 03:33:30 AM »

No need to ask again and again. If someone sees your question AND knows an answer, he will answer.

Quote
how do i check if a person is in a battle like if ($battle=true)

You can't.

Well, you can do - but you have to write your own code for it. With the original code it is not possible to cheat the way your players do.
Maybe you can read out and check the "badguy" field?

The best way would be to repair your nav-system!
(Hidden source makes it impossible to help with your problem.)

For installation of PHP on Mac: Read the ... manual. Wink
Logged
lonnyl
Guest
« Reply #3 on: July 23, 2004, 05:36:28 AM »

Checking the badguy field is the only way I could think of.....

$global $badguy;
if ($badguy['creaturename'] <> ""){
//battle is active
}
Logged
kodysumter
Guest
« Reply #4 on: July 24, 2004, 07:13:40 PM »

ok, thx, for 1, the installation thihng doesnt work on my mac =(....and i dont know why but must be server side but the badnav doesnt work rihgt either....and i dont know where to put in the bad nav that code you mentioned lonnyl...maybe i can just set battle=false? wouldnt that work? if so how do i do it?
Logged
Akuma
Guest
« Reply #5 on: July 27, 2004, 06:28:13 PM »

I'm pretty sure I know what your problem is, because I, as you know, dealt with it a lot at luekinghost. The problem is, if you are using the luekinghost badnav.php, it is very poorly designed and can easily be used to cheat. What I would advise is to go to sourceforge and download the .0.9.7 badnav.php file and upload that one to your server. That should take care of your problem. Keep in mind that I've never played on your server nor looked at your code, so I'm not positive if you're using a luekinghost-style badnav or not....but the problem sounds the same. Hope this helps.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Welcome to DragonPrime - The LoGD Resource Community!

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Who's Online
36 Guests, 0 Users
DragonPrime LoGD
Recent Topics
Home Forums News Links Downloads Login Register Advanced Search