DragonPrime - LoGD Resource Community
Welcome Guest
  • Good afternoon, Guest.
    Please log in, or register.
  • July 22, 2019, 04:15:04 PM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1]   Go Down
  Print  
Author Topic: "All Salt on hand was lost!"... Help! Where is the salt coming from?!?!  (Read 3519 times)
0 Members and 1 Guest are viewing this topic.
DaveS
Mod God
*****
Offline Offline

Posts: 1544


Dfly... you know, as in DaveFly


View Profile
« on: February 26, 2006, 10:10:46 AM »

Okay, I'm stumped on this one.  I'm writing these Signet Dungeons... when I get killed by anything in the dungeon I get the following output:

`3All Salt on hand was lost!

(Including the `3 that stays intact)

This is vexing to me for several reasons:
1.  I cannot figure out where in the code it is calling for this statement.
2.  There is NO mention of Salt anywhere in the code.
3.  I'm not aware of where "salt" would be mentioned in the core somewhere to output here.

My thoughts?  Okay, so since I am using Lonny's Abandoned castle as a template and I'm not 100% sure why he had this line in the code, I wonder if it is calling up something that I'm unaware of:
Code:
if (in_array($op, $knownmonsters) || $op == "fight" || $op == "run") {
signetd2_fight($op);
die;
}

Is it that extra little line:  die;

Anyone have any clues? I find it interesting yet disturbing.

If  you want to take a look at the full code to help me, just download the signetd1 Aria Dungeon to see if it's buried somewhere in there.

So I need some help:
1.  How do I get rid of that line?
2.  How do I do it without causing a meltdown in the rest of my code?
Logged

Check out my Last Module:
The Dragon Eggs Expansion
http://dragonprime.net/index.php?topic=8474.0

About my Retirement:
http://dragonprime.net/index.php?topic=9080

See my complete module list here:
http://dragonprime.net/index.php?topic=3038.0
XChrisX
Global Moderator
Mod God
*****
Offline Offline

Posts: 4647

Be aware of the squirrel!


View Profile WWW
« Reply #1 on: February 26, 2006, 10:17:16 AM »

You should look for all modules which use the hook "battle-defeat". It's quite likely, that one of these causes the problem (or do a fulltext search through all your files for above mentioned string).
Logged

Running for more than three years now:
DaveS
Mod God
*****
Offline Offline

Posts: 1544


Dfly... you know, as in DaveFly


View Profile
« Reply #2 on: February 26, 2006, 10:37:08 AM »

Okay, I figured it out thanks to Sichae...

I had installed altcurrency.php and that was coming up as part of a hook from that module.

Isn't that interesting?  I thought so.  Thanks Sichae!
Logged

Check out my Last Module:
The Dragon Eggs Expansion
http://dragonprime.net/index.php?topic=8474.0

About my Retirement:
http://dragonprime.net/index.php?topic=9080

See my complete module list here:
http://dragonprime.net/index.php?topic=3038.0
Jdrid
Guest
« Reply #3 on: February 26, 2006, 01:42:27 PM »

yeah, thats the the default currency they start you with when it's installed.
Couldn't help with the `3, unless there is an extra `3 in the code of it...
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Please take the time to read the FAQ and browse the DragonPedia

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
42 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search