DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • June 22, 2018, 11:42:30 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1]   Go Down
  Print  
Author Topic: List of server  (Read 3407 times)
0 Members and 1 Guest are viewing this topic.
Excalibur
Member
Mod God
*****
Offline Offline

Posts: 573


I'm a newbie, plz forgive me!


View Profile WWW
« on: May 09, 2004, 06:42:28 AM »

I've noticed that in the list of servers that are listed on the link page LoGD Net the control char for white color (`&) it shows before changing the color to white like this:
Legend of the amp;[/i]Green Dragon ITALIANO Totalmente tradotto !!
                   ^^^^
Is there a way to avoid this and use white (not grey) color ?

Rgds Excalibur
Logged

Spock: Random chance seems to have operated in our favor.
McCoy: In plain, non-Vulcan English, we've been lucky.
Spock: I believe I said that, Doctor.
Kendaer
Guest
« Reply #1 on: May 09, 2004, 11:15:57 AM »

This is actually fixed in the 0.9.8 source.
It happens because we need to htmlentity encode stuff in some places in order to prevent things from being misunderstood by various things during use.

The problematic line for you is
            output("<tr><td><a href='".HTMLEntities($row[address])."' target='_blank'>".soap(HTMLEntities($row[description]))."`0</a></td></tr>",true);
 
in logdnet.php

(right toward the bottom)

If you rewrite that section of code as
            $row['description'] = soap(htmlentities($row['description']);
            $row['description'] =  str_replace("`&amp;", "`&", $row['description']);
            output("<tr><td><a href='".HTMLEntities($row[address])."' target='_blank'>".$row['description']."`0</a></td></tr>",true);
 
It should work.
Logged
Excalibur
Member
Mod God
*****
Offline Offline

Posts: 573


I'm a newbie, plz forgive me!


View Profile WWW
« Reply #2 on: May 09, 2004, 01:46:23 PM »

If you rewrite that section of code as
            $row['description'] = soap(htmlentities($row['description']);
It should work.
it miss a parenthesis in the end:
$row['description'] = soap(htmlentities($row['description']));

Now it works fine Smiley

Thx Kendaer  Cheesy

Rgds Excalibur
Logged

Spock: Random chance seems to have operated in our favor.
McCoy: In plain, non-Vulcan English, we've been lucky.
Spock: I believe I said that, Doctor.
Kendaer
Guest
« Reply #3 on: May 10, 2004, 10:49:18 AM »

it miss a parenthesis in the end:
$row['description'] = soap(htmlentities($row['description']));

Now it works fine Smiley

Thx Kendaer  Cheesy

Rgds Excalibur


Yeah.. I was writing that from my head since the code in 0.9.8 is pretty different there.  Glad it works for you.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Please take the time to read the FAQ and browse the DragonPedia

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
47 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search