DragonPrime - LoGD Resource Community
Welcome Guest
  • Good evening, Guest.
    Please log in, or register.
  • May 29, 2016, 12:34:33 AM
Home Forums News Links Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
IRC Channels
Search

Pages: [1]   Go Down
  Print  
Author Topic: Bad nav problems  (Read 2457 times)
0 Members and 1 Guest are viewing this topic.
MajinLoki
Guest
« on: October 10, 2005, 03:48:10 PM »

I am having problems beyond problems with my site.

Number 1, if anyone gets a bad nav page, it doesn't fix their bad navs. and they remain stuck on the bad navs page forever.

Number 2, I have one user getting the php access violation.  It is only 1 user and we deleted his account.

I tried installing the navdemon, but no one gets the page when they get bad navs.

How do I fix these problems?  I'm about ready to pull out my hair because I've tried adding a sql query to just fix everyones navs and that isn't working at all.
Logged
Dannic
Guest
« Reply #1 on: October 10, 2005, 04:39:06 PM »

The only thing I can suggest is to manually edit the affected users accounts.  You may want to start disabling modules until the problem goes away.
Logged
MajinLoki
Guest
« Reply #2 on: October 13, 2005, 07:15:45 AM »

We deleted his account and he made a new one from scratch.  He still gets the error.  I upgraded from 1.0.2 to 1.0.3 I think before he started getting the problem.  Now, more users are having the same issue.

I am running my installation on a Widnows server wit hthe mysql database on a different server.

I have tried uninstalling a lot of modules, hoping that will fix it.  I tried playing myself and now I am getting the errors now too.

On 1.0.2 I commented out the use of semaphores and that installation seemed to work just fine.  I am wondering if there is an issue with using semaphores on windows machines or where the database is not on the file server.  The main page I am having this issue on is newday.php, which uses semaphores.

Here is my current module configuration.
http://lotgd.otherworld-rpg.com/about.php?op=listmodules&c=2-070519

EDIT:
I had a friend check out my newday.php since that is where the access violation is occuring most frequently.  Here's an image.

http://img331.imageshack.us/img331/5200/grrr9dl.jpg

My friend said it is due to multiple page header's being written out.  When I get this error I can usually refresh and it goes away.
« Last Edit: October 13, 2005, 08:19:33 AM by MajinLoki » Logged
Kendaer
Guest
« Reply #3 on: October 13, 2005, 10:04:59 AM »

It sounds very suspiciously like your windows version of PHP is broken when it comes to semaphores.

None of the unix installations have had this problem, and Central specifically runs with a non-local MySQL database.

This is not something that can be fixed in the LoGD game code and must be addressed in your PHP/webserver environment.   I would suggest you look at the EasyPHP setup which other people have been successfully using on Windows.  If you're already using that, I have no suggestions for you except possibly filing a bug with them to let them know you are getting this access violation.
Logged
kickme
Global Moderator
Mod God
*****
Offline Offline

Posts: 1589


Yay for elephants!


View Profile WWW
« Reply #4 on: October 13, 2005, 08:28:34 PM »

I say get rid windoze and get a decent computer
Logged

Waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka waka
Talisman
Administrator
Mod God
*****
Offline Offline

Posts: 5462



View Profile WWW
« Reply #5 on: October 13, 2005, 08:35:09 PM »

I say get rid windoze and get a decent computer

I didn't realize running windoze was synonymous with having a crappy computer.   Tongue

Please try to keep the comments constructive, thanks...
Logged

Play the latest beta version here on DragonPrime
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Version 1.1.2 is the current supported version and is available for download.

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Who's Online
43 Guests, 0 Users
DragonPrime LoGD
Recent Topics
Home Forums News Links Downloads Login Register Advanced Search