DragonPrime - LoGD Resource Community
Welcome Guest
  • Good afternoon, Guest.
    Please log in, or register.
  • February 20, 2019, 02:00:42 PM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1]   Go Down
  Print  
Author Topic: 98rndbounty  (Read 2470 times)
0 Members and 1 Guest are viewing this topic.
enderwiggin
Guest
« on: January 07, 2005, 04:48:35 AM »

I downloaded this module, and uploaded it to my module directory.

Then module.php wouldn't display, because it was giving me an error.  The only way to get module.php to display properly was to delete rndbounty.php

I checked, and the module was converted to .9.8, and looked valid.  Now, I don't know PHP, but I do know basic programming syntax, and it appeared to be a very basic syntax error in the .9.8 conversion.

Code:
function rndbounty_getmoduleinfo(){
   $info = array(
      "name"=>"Random Bounty",
      "version"=>"1.21",
      "author"=>"`#Lonny Luberts",
      "category"=>"Forest Specials",
      "download"=>"http://dragonprime.net/users/lonnyl/98rndbounty.zip"
   );
      "settings"=>array(
         "Random Bounty Settings,title",
         "max"=>"Maximum Bounty,int|10000",
      ),
   return $info;
}

I have changed it to:

Code:
function rndbounty_getmoduleinfo(){
   $info = array(
      "name"=>"Random Bounty",
      "version"=>"1.21",
      "author"=>"`#Lonny Luberts",
      "category"=>"Forest Specials",
      "download"=>"http://dragonprime.net/users/lonnyl/98rndbounty.zip",
     "settings"=>array(
        "Random Bounty Settings,title",
        "max"=>"Maximum Bounty,int|10000",
      ),
   );
   return $info;
}

I haven't tested the module, but the change atleast lets me upload and install the module.  It's such a minute fix, that I'm not asking to take any credit for it.  You can test my change by downloading the file at:

http://dragonprime.net/users/enderwiggin/rndbounty.zip

If this works, I'd just like to see Lonny's verison fixed.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Version 1.1.2 is the current supported version and is available for download.

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
38 Guests, 1 User
Raeshi
Home Forums News Downloads Login Register Advanced Search