DragonPrime - LoGD Resource Community
Welcome Guest
  • Good morning, Guest.
    Please log in, or register.
  • January 17, 2018, 06:54:35 AM
Home Forums News Downloads Login Register Advanced Search
* * *
DragonPrime Menu
Login
 
 
Resource Pages
Search

Pages: [1] 2 3   Go Down
  Print  
Author Topic: Prerelease 14 available  (Read 9038 times)
0 Members and 1 Guest are viewing this topic.
Kendaer
Guest
« on: February 15, 2005, 11:06:10 PM »

And on the anniversary of Dragonprime's opening too.

Lots of bug fixes and changes.  Some new features including modules by CortalUX.

A fair handful of new modules, the 'check_' preference type that CortalUX asked for, and the ability to order hooks on a modulehook by a priority (see the function module_addhook_priority and the newbieisland and testmodule for examples of it's use).

Enjoy!
Logged
enderwiggin
Guest
« Reply #1 on: February 15, 2005, 11:24:53 PM »

I'll be home in two hours, and installing this!
Logged
Perdition
Guest
« Reply #2 on: February 16, 2005, 12:47:12 AM »

Getting some debug output saying...

Warning: reset(): Passed variable is not an array or object in \lib\modules.php on line 388

Warning: Variable passed to each() is not an array or object in \lib\modules.php on line 389

The section of code is (Line 386-402)...


if ($session['user']['superuser'] & SU_DEBUG_OUTPUT && !isset($hookcomment[$hookname])){
      rawoutput("<!--Module Hook: $hookname; allow inactive: ".($allowinactive?"true":"false")."; only this module: ".($only?"true":"false"));
      reset($args);  
      while (list($key,$val)=each($args)){
         $arg = $key." = ";
         if (is_array($val)){
            $arg.="array(".count($val).")";
         }elseif (is_object($val)){
            $arg.="object(".get_class($val).")";
         }else{
            $arg.=htmlentities(substr($val,0,25));
         }
         rawoutput("  arg: $arg");
      }
      rawoutput("  -->");
      $hookcomment[$hookname]=true;
   }


It's the reset($args) statement it seems to have trouble with.  Could anyone suggest anything?
Logged
enderwiggin
Guest
« Reply #3 on: February 16, 2005, 01:13:27 AM »

I'm assuming this is after the installer already went through and did it's thing?  And I'm assuming you did an upgrade?
Logged
Jim
Guest
« Reply #4 on: February 16, 2005, 02:38:20 AM »

I'm getting after the upgrade at the top of every page:

Warning: reset(): Passed variable is not an array or object in /lib/modules.php on line 388

Warning: Variable passed to each() is not an array or object in /lib/modules.php on line 389
Logged
Damien
Guest
« Reply #5 on: February 16, 2005, 02:57:01 AM »

I upgraded from pr11 to pr14 and somehow it removed location field from creatures table so now it's giving me error everytime I beat forest creature :|

Here's the error:

SELECT location FROM creatures WHERE creatureid='224'
Unknown column 'location' in 'field list'
Logged
sixf00t4
Mod God
*****
Offline Offline

Posts: 1916



View Profile WWW
« Reply #6 on: February 16, 2005, 03:02:22 AM »

wasn't directed to installer.php automatically, and during sql build and install got
Code:
Error: Specified key was too long. Max key length is 500

CREATE TABLE untranslated (
intext text NOT NULL ,
language varchar(10) NOT NULL ,
namespace varchar(255) NOT NULL ,
PRIMARY KEY (intext(255),language,namespace),
KEY language (language),
KEY intext1 (intext(255),language)) Type=MyISAM
no errors like the others yet.
Logged

Perdition
Guest
« Reply #7 on: February 16, 2005, 03:31:30 AM »

Getting some debug output saying...

Warning: reset(): Passed variable is not an array or object in \lib\modules.php on line 388

Warning: Variable passed to each() is not an array or object in \lib\modules.php on line 389

The section of code is (Line 386-402)...


if ($session['user']['superuser'] & SU_DEBUG_OUTPUT && !isset($hookcomment[$hookname])){
      rawoutput("<!--Module Hook: $hookname; allow inactive: ".($allowinactive?"true":"false")."; only this module: ".($only?"true":"false"));
      reset($args);  
      while (list($key,$val)=each($args)){
         $arg = $key." = ";
         if (is_array($val)){
            $arg.="array(".count($val).")";
         }elseif (is_object($val)){
            $arg.="object(".get_class($val).")";
         }else{
            $arg.=htmlentities(substr($val,0,25));
         }
         rawoutput("  arg: $arg");
      }
      rawoutput("  -->");
      $hookcomment[$hookname]=true;
   }


It's the reset($args) statement it seems to have trouble with.  Could anyone suggest anything?

The game seems to run fine, just with some complaints from the debug. I run two servers, the one with the error was upgraded from pre12 to pre14, my development server upgraded fine from 13-14. and is not showing any problems. Seems to be pointing at something missed in the upgrade from anything before pre 13 (but that's a stab in the dark guess).
« Last Edit: February 16, 2005, 03:33:06 AM by Perdition » Logged
Damien
Guest
« Reply #8 on: February 16, 2005, 03:45:31 AM »

Blah, there should not even be location field anymore so I uninstalled modules (200, sick) and my problem disappeared. Now I need to hunt the module which is causing the problem (probably the module is made by me  Grin). So the problem wasn't with the installer, sorry.
Logged
Dannic
Guest
« Reply #9 on: February 16, 2005, 03:46:11 AM »

I upgraded from pr11 to pr14 and somehow it removed location field from creatures table so now it's giving me error everytime I beat forest creature :|

Here's the error:

SELECT location FROM creatures WHERE creatureid='224'
Unknown column 'location' in 'field list'

This is an old problem.  Check for other posts on this same subject.
Logged
estin
Guest
« Reply #10 on: February 16, 2005, 05:10:51 AM »

wasn't directed to installer.php automatically, and during sql build and install got
Code:
Error: Specified key was too long. Max key length is 500

CREATE TABLE untranslated (
intext text NOT NULL ,
language varchar(10) NOT NULL ,
namespace varchar(255) NOT NULL ,
PRIMARY KEY (intext(255),language,namespace),
KEY language (language),
KEY intext1 (intext(255),language)) Type=MyISAM
no errors like the others yet.

exactly the same behaviour here

everything seems to run great though...
Logged
Jim
Guest
« Reply #11 on: February 16, 2005, 05:34:14 AM »

Seems to be pointing at something missed in the upgrade from anything before pre 13

Mine happened on a .13 to .14 upgrade.

wasn't directed to installer.php automatically

same with me.
Logged
Sichae
iMod God
SVN Users
Mod God
*
Offline Offline

Posts: 3458


If ya didn't get it by now... you're hopeless...


View Profile WWW
« Reply #12 on: February 16, 2005, 06:08:55 AM »

Hmmm, how odd. I just went from PR 13 to PR 14 and am seeing no debug output error, nothing really out of the ordinary...

Of course, I had to type installer.php into the address bar, but it isn't that hard.
« Last Edit: February 16, 2005, 06:09:43 AM by Sichae » Logged

If you didn't understand anything in the above post, don't try to attempt anything suggested.

lonnyl
Guest
« Reply #13 on: February 16, 2005, 06:15:40 AM »

I also had to enter the install.php url manually....

I did get the error... this is becuase I have the su debug output turned on.  Your players will not notice this error....

I for the time being commented out the offending lines of code so that I did not have to look at the ugly error.  
Logged
Sichae
iMod God
SVN Users
Mod God
*
Offline Offline

Posts: 3458


If ya didn't get it by now... you're hopeless...


View Profile WWW
« Reply #14 on: February 16, 2005, 06:25:22 AM »

I did get the error... this is becuase I have the su debug output turned on.  Your players will not notice this error....

I am the only person on my server with Debug Output even enabled...
Logged

If you didn't understand anything in the above post, don't try to attempt anything suggested.

Pages: [1] 2 3   Go Up
  Print  
 
Jump to:  


*
DragonPrime Notices
Please take the time to read the FAQ and browse the DragonPedia

Support Us
No funds raised yet this year
Your help is greatly appreciated!
Recent Topics
DragonPrime LoGD
Who's Online
25 Guests, 0 Users
Home Forums News Downloads Login Register Advanced Search