DragonPrime - LoGD Resource Community

Game Administration, Installation and Configuration => Game Administration Chat => Topic started by: Detahas on April 16, 2005, 05:43:25 AM



Title: ummm..bug ^^
Post by: Detahas on April 16, 2005, 05:43:25 AM
then i installed the LOTG 1.0.2 now then i install some modules i get this
etc: then i installed avatars module and went back to the grotto then bellow the shoutbox was this
Installing Avatars Module.
Be sure to set your settings.
PHP Warning: "avatars_dohook did not return an array in the module avatars for hook superuser."
in /home/black/public_html/lotgd/lib/modules.php at 510.

Call Stack:
2: trigger_error("<b>avatars_dohook</b> did...", 512) called from /home/black/public_html/lotgd/lib/modules.php on line 510
3: modulehook("superuser", Array(), true) called from /home/black/public_html/lotgd/superuser.php on line 77
same problem(of course some text is different) with NPCs and lonnyl's castle...
ummm Anyone..help ?


Title: Re:ummm..bug ^^
Post by: chicu on April 16, 2005, 05:44:57 AM
that is no bug, it's just a warning!


Title: Re:ummm..bug ^^
Post by: Detahas on April 16, 2005, 05:47:12 AM
ummm... warning...but can anyone tell me why it is here ?
and also wgy similar "warnings apear then i installed some NOCs in all city'es bellow the shoutbox  ???


Title: Re:ummm..bug ^^
Post by: chicu on April 16, 2005, 05:49:44 AM
i do not know why it's there but this warning was also @ the 1.0.0version.
so I think that shows you instabile modules or something like that


Title: Re:ummm..bug ^^
Post by: lonnyl on April 16, 2005, 05:52:54 AM
You need to look a little harder... this error has been discussed at length..... it is because the avatars module (and a number of others) are (or may be) missing a return $args; statement in their do_hook function.....  Most if not all of these modules have been fixed, so you will need to update them or perform the reapairs yourself.


Title: Re:ummm..bug ^^
Post by: Detahas on April 16, 2005, 05:54:12 AM
well i UPDATED THEM TO THEIR LATEST versions... same problem happens ^^...


Title: Re:ummm..bug ^^
Post by: XChrisX on April 16, 2005, 06:19:00 AM
Well, the authors of some modules are not too active... so some may not have changed their modules to the new needs...


Title: Re:ummm..bug ^^
Post by: lonnyl on April 16, 2005, 06:23:40 AM
And modules like Avatars... have been updated by others....

You will find the updated avatars in Sixf00t4's shared folder....

compare the diffence between the avatar mod you have and the fixed one... this should give you an idea on how to fix the others that are giving you problems.


Title: Re:ummm..bug ^^
Post by: Detahas on April 16, 2005, 06:29:45 AM
ok thanks... but the same happenedwith Bladder... and yours castle and election :[ ... my users liked your castle very much :D


Title: Re:ummm..bug ^^
Post by: lonnyl on April 16, 2005, 06:40:04 AM
All of my modules have been updated and the newest versions will not give you those errors any longer.


Title: Re:ummm..bug ^^
Post by: Detahas on April 16, 2005, 06:49:47 AM
thank you for helping... now all works just fine ^^


Title: Re:ummm..bug ^^
Post by: CortalUX on May 04, 2005, 08:01:47 AM
My avatars should have the return $args in it.


Title: Re: ummm..bug ^^
Post by: danbi on July 26, 2006, 04:09:20 AM
The download that's on dragonprime.net needs an return $args in
function avatars_dohook();

© 2019 DragonPrime - LoGD Resource Community
Email Talisman: talisman -at- gmail.com
&oeXs)2U7=V BmܲV.U e=;p\}eG )Jj} C5EH7ˤH=j } mo|*Ŋw{drV_@IV>/- TFQJ׀̀Ve}l1,V O iNYx͘$e$;
Forums: Powered by SMF 1.1.21 | SMF © 2006-2007, Simple Machines