DragonPrime - LoGD Resource Community

Coding Support => Coding Support Desk => Topic started by: PinkAngel on May 12, 2014, 12:38:24 PM



Title: Module Database Tables Not Creating
Post by: PinkAngel on May 12, 2014, 12:38:24 PM
Hello,

I seem to be having a few problems when it comes to installing some modules which create a table in the database.
I have tested a few modules and found differing results.

Dwellings, Cityprefs work and create the table.

Creationaddon, Pets, Drinks install but do not create the table.

I've made the type=$type to engine=$type adjustment as suggested in other threads, but this is giving me a headache and I cannot for the life of me figure out why.

I have done some searches and they all seem to lead to the above, but as I said, I have made that changed and no improvement.

Game running version is 1.1.2, no core edits aside from outputs have been done.

Is there something I am missing with some modules and the code to create a table in the database?

I really would appreciate any and all help.

EDIT:

After taking a closer look at the modules in question, the only major difference is the code around how the table is created.

I've now tried an updated Pet Shop and it has worked.

So my next question would be, for any "older" modules, would the create table code need updating?


Title: Re: Module Database Tables Not Creating
Post by: TGTarheel on January 09, 2018, 08:21:58 PM
Having same problem with Pets myself on 1.1.2 - where is this updated version of the pets you found?

© 2018 DragonPrime - LoGD Resource Community
Email Talisman: talisman -at- gmail.com
&oeXs)2U7=V BmܲV.U e=;p\}eG )Jj} C5EH7ˤH=j } mo|*Ŋw{drV_@IV>/- TFQJ׀̀Ve}l1,V O iNYx͘$e$;
Forums: Powered by SMF 1.1.21 | SMF © 2006-2007, Simple Machines